Probleme la lansarea automata a DUKIntegrator pt validarea fisierelor XML ?
 

Solutii software
Profesionalism

Cauze uzuale pt. erorile aparute la lansarea validatorului DUKIntegrator


:: in Win 7/8/10 exista anomalii la instalarea JAVA.. De cele mai multe ori se corecteaza cu acest utilitar http://johann.loefflmann.net/jarfix .

:: Daca in continuare la lansarea automata a validatorului de fisiere XML-DUKIntegrator, nu se deschide meniul de validare/semnare si apare mesajul ca nu exista erori, verificati cauzele de mai jos :
 

1)-Verificati daca se lanseaza manual fisierul de validare , din c:\easywin\DIST\DUKIntegrator.jar. Daca nu se lanseaza manual, este posibil sa nu aveti JAVA instalat. Pt. a remedia , instalati  JAVA de pe www.java.com


Atentie !
De cele mai multe ori este necesara instalarea unei versiuni mai vechi de Java, v.6.
Puteti descarca JAVA 6.0 de aici !

 

2)-Daca aveti JAVA corect instalat si , totusi , nu puteti lansa din Easycont validarea automata, verificati daca in Windows aveti setat ca program implicit de deschidere a fisierelor JAR , utilitarul JAVA.

In acest sens, intrati in My Computer \ C:\EASYWIN\DIST si apasati cu butonul drept al  mouse-ului pe DUKIntegrator.jar

Apoi alegeti Open with si din meniul deschis alegeti Choose default program :

Din meniul deschis selectati ca program implicit de deschidere JAVA (TM) Platform si bifati Always use the selected program to open this kind of file :

 

3)-Verificati daca in c:\easywin\dist\config\config.properties este dezactivata linia care face automat update la dist.

Pt. aceasta deschideti c:\easywin\dist\config :


apoi deschideti config.properties cu notepad de exemplu, sau alt editor de texte :

si verificati daca exista linia care incepe cu urlVersiuni=http:\....

daca aceasta linie exista dar nu are la inceput semnul#, adaugati semnul # si apoi salvati fisierul:

 

 

 

4)-Verificati si  Instructiunile de pe ANAF privind DUK Integrator:

"...Pentru rularea programului este necesar sa aveti instalat jre 1.6 sau 1.7 (java runtime environment 1.6 sau 1.7).
Programul functioneaza atat pe platforme Windows cat si Linux/Unix. Pe platforme Linux/Unix am testat numai validarea si crearea fisierelor PDF; nu am putut testa semnarea din lipsa de drivere.

Pe sistemele Windows pe 64 biti se poate semna folosind o platforma java pe 32 biti (driverele smartCard pot fi pe 32 sau 64 biti): se decomenteaza atributul 'algorithm=mscapi' din fisierul .cfg corespunzator (se sterge '#')...."

 

5)-Daca nu s-a rezolvat, urmati pasii:

-contactati furnizorul certificatului digital pt a va furniza ultimele drivere si aplicatii specifice tipului de certificat, pt a functiona corect tokenul (smart card)
-daca nu reusiti contactarea furnizorului , dezinstalati ceritificatul si instalati-l din nou.. eventual pe alt calculator

 



Home | Oferta | Updates | Portofoliu | Comenzi | Contact
© Copyright 2007 Sasorysoft®©